Dongle WiFi TPLINK WN821N V6 2357:0107

Vous avez une procédure de configuration ou un conseil pour configurer un matériel particulier, partagez votre expérience dans cette partie.
Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 420
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Dongle WiFi TPLINK WN821N V6 2357:0107

Message par le Manchot Masqué » mar. 18 sept. 2018, 22:20

Cette notice reprend le résultat d'une recherche qui m'a valu plusieurs heures, et concerne le dongle WiFi sus-nommé.
Ma Ubuntu 18.04.1 LTS prenait en charge le matériel via le driver /lib/firmware/rtlwifi/rtl8192eu_nic.bin sur mon noyau 4.15.0-33-generic.
En mode client WiFi - pas de problème : ce driver fonctionne correctement et suffit à se connecter aux points d'accès.
En revanche, quand il s'agit d'émuler soit-même un point d'accès via le paquet hostapd, ce dernier ne parvient pas à passer la carte en mode AP, alors que le dongle est censé parfaitement supporté cette fonctionnalité, en WPA2/PSK pour plus de sécurité.
En clair : le driver de base n'est pas complet en terme de fonctionnalités.
La manipulation qui a fonctionné (merci Elysium - https://forum.ubuntu-fr.org/viewtopic.php?id=2019113):

Code : Tout sélectionner

mkdir /usr/local/src/WN821N
cd /usr/local/src/WN821N
git clone https://github.com/jeremyb31/rtl8192eu-linux-driver
cd rtl8192eu-linux-driver/
apt-get install libelf-dev
dkms add .
dkms install rtl8192eu/1.0
On débranche la clé et on vire l'ancien driver encore présent :

Code : Tout sélectionner

rmmod rtl8xxxu
On charge le module et on rebranche la clé :

Code : Tout sélectionner

modprobe 8192eu
Et là, on teste en ligne de commande :

Code : Tout sélectionner

hostapd -dd /etc/hostapd/hostapd.conf 
Contenu de mon /etc/hostapd/hostapd.conf (à adapter chez vous) :

Code : Tout sélectionner

interface=wlan0
driver=nl80211
bridge=br0
country_code=FR
ieee80211d=1
ssid=YOUPEE_C_LA_RENTREE_AU_BOULOT_LES_JEUNES_!
hw_mode=g
channel=6
wme_enabled=0
macaddr_acl=0
auth_algs=1
wpa=2
wpa_passphrase=Si_tu_n_as_pas_le_bon_mot_de_passe_et_bien_tu_trepasses_!
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
A noter ici que j'utilise l'interface wlan0 en bridge sur mon interface ethernet filaire RJ45 :

Code : Tout sélectionner

# brctl show br0
bridge name	bridge id		STP enabled	interfaces
br0		8000.1c7ee5108959	no		eth1
							wlan0
Pour cela j'ai arrêté le network-manager et j'y suis allé comme un bourrin :

Code : Tout sélectionner

service network-manager stop
j'ai viré avahi/mDNS qui me cassait un peu trop les pieds (un systemctl stop avahi-daemon.service n'arrêtait pas le service, ce qui n'est pas normal de mon point de vue - si vous avez des explications en la matière, je suis preneur, mais systemd commence sérieusement à me sortir par les trous du nez)

Code : Tout sélectionner

apt-get remove avahi-daemon  avahi-utils
puis réinitialisé les cartes :

Code : Tout sélectionner

ifconfig eth1 up
ifconfig eth1 0.0.0.0
ifconfig wlan0 up
ifconfig wlan0 0.0.0.0
construit le bridge au niveau 2

Code : Tout sélectionner

brctl addbr br0
brctl addif br0 eth1
brctl addif br0 wlan0
brctl show br0
appelé DHCP en renfort pour obtenir une IP automatique pour mon pont (après avoir évidemment vérifié qu'aucun client DHCP ne traînait encore en mémoire...)

Code : Tout sélectionner

killall dhclient
dhclient br0
Et voilà !

À noter que le site de realtek est de plus en plus négligé d'année en année. Je pense même qu'il mériterait un lauréat comme honte absolue du web : même les moteurs de recherche ne sont plus fonctionnels ! Impressionnant de nullité !
Si ce fabricant n'était pas celui de la puce processeur du Raspberry Pi, et qu'on ne trouvait pas des drivers WiFi fonctionnels grâce à la communauté GNU/Linux, il mériterait le boycott direct !

Répondre