Asus eeepc R105D - bug son - Ubuntu 16.04 LTS

Vous avez une procédure de configuration ou un conseil pour configurer un matériel particulier, partagez votre expérience dans cette partie.

Asus eeepc R105D - bug son - Ubuntu 16.04 LTS

Messagede le Manchot Masqué » Jeu 23 Juin 2016, 13:36

Le R105D n'est pas un eeepc très récent, mais il tient bien la route sous Ubuntu 16.04 LTS, et même mieux que certains portables beaucoup plus récents en AMD E1... C'est d'ailleurs indécent de voir ainsi des machines récentes, vendues en magasin avec 4GO de RAM, plus lentes que de "vieux" netbooks qui étaient vendus autour de 250€ il y a encore 5 ans...
Problème rencontré sur ce portable : le son fonctionne d'emblée au niveau casque, mais pas au niveau des enceintes intégrées. Le chipset son est un ALC269.
Après beaucoup de recherches et de tests infructueux, la solution donnée par https://forums.opensuse.org/showthread.php/494636-Audio-not-working-on-Asus-X750J est finalement la bonne.

= 1) Test de la solution : =

- CTRL-ALT-F2 pour passer en terminal
- rentrer le mot de passe root
- arrêter lightdm et installer sox :
Code: Select All Code
service lightdm stop
apt-get install sox

- décharger le driver et le recharger avec les options de test :
Code: Select All Code
rmmod snd-hda-intel && modprobe snd-hda-intel model=laptop-amic position_fixed=0

- tester le son :
Code: Select All Code
play /usr/share/sound/purple/login.wav

ou tout autre fichier wav qui traîne sur le disque dur - une seule commande pour les trouver tous :
Code: Select All Code
locate *wav
...
- si toujours rien en sortie, lancer :
Code: Select All Code
alsamixer

pour régler les sorties et les niveaux en console.
Il faut utiliser la touche flèche droite pour aller sur headphone, puis M (mute/unmute) pour activer/désactiver la sortie headphone, puis monter le niveau de headphone au maximum avec la flèche haut, et enfin ESC pour revenir au terminal.

= 2) Bug sur alsa =

Sur ce dernier point, la 16.04 semble souffrir d'un autre bug sonore assez ennuyeux. Normalement, la commande
Code: Select All Code
alsactl store

est censée mémoriser les réglages actuels, mais pour une raison inconnue, ça ne marche pas.
J'ai ensuite essayé dans un terminal :
Code: Select All Code
alsactl --file ~/.config/asound.state store

et placé la commande
Code: Select All Code
alsactl --file ~/.config/asound.state restore

à la fin du fichier ~/.profile, et là, enfin, le réglage a été conservé.

J'avais aussi tenté de mettre la ligne
Code: Select All Code
options snd-hda-intel model=laptop-amic position_fixed=0

dans /etc/modprobe.d/alsa-base.conf
et de reconstruire le système de fichiers de démarrage initramfs avec les modules noyau via
Code: Select All Code
update-initramfs -u -v

mais au reboot, ça ne changeait rien.
En fait, alsa n'est pas encore lancé dans la phase d'initramfs, donc à moins de forcer le chargement du module dans /etc/modules, ce que je n'ai pas fait, et ce qui n'est normalement pas utile...

J'avais encore fait d'autres tentatives, via plusieurs autres fichiers, mais à chaque fois, pulseaudio remettait ses réglages par défaut. En espérant que ce petit bug sera résolu dans la mise à jour du 21/7/16...
Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
 
Messages: 337
Inscription: Lun 26 Mai 2008, 21:05
Localisation: Guebwiller
Distribution: Debian, Ubuntu
Niveau: Moitié plein !

Retourner vers Sur un matériel

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron