Cartes NVIDIA - astuce d'installation pour la Ubuntu 14.04

Vous avez une procédure de configuration ou un conseil pour configurer un matériel particulier, partagez votre expérience dans cette partie.
Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 347
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Cartes NVIDIA - astuce d'installation pour la Ubuntu 14.04

Message par le Manchot Masqué » mar. 17 juin 2014, 12:19

Seule ombre trouvée au tableau de la dernière 14.04 LTS, les cartes NVIDIA conduisent parfois à un plantage du serveur graphique. La raison est simple : pour imposer l'interface graphique Unity au démarrage de sa distribution, Canonical a fait le choix d'utiliser le driver Nouveau, sensé offrir de meilleures performances que le driver VESA "universel" de base.

Problème : le driver Nouveau n'est pas encore entièrement au point, et plante sur des configurations un peu anciennes. En attendant donc que Canonical (et Debian...) finissent par comprendre que l'environnement MATE est un choix bien plus logique comme environnement par défaut, il convient donc de désactiver manuellement le driver Nouveau.

Au démarrage, on reste donc appuyé sur la touche MAJ jusqu'à l'apparition de GRUB, on tape ensuite sur la touche e pour éditer les paramètres de lancement du noyau, on se déplace avec les flèches de direction sur la ligne qui commence par linux .., et on remplace le quiet splash par nouveau.modeset=0.

Attention : lors de cette opération, le clavier est en mode QWERTY ! Une fois le changement opéré, un CTRL-X pour lancer le démarrage, et l'installation doit ensuite se dérouler sans problème (sauf si vous avez le malheur d'avoir acheté une machine windows 8 avec bios UEFI, mais ça c'est une autre histoire...).

Une fois l'installation terminée, il faut, sous utilisateur root (sudo bash), rajouter les options nouveau.modeset=0 dans /etc/default/grub, et faire un update-grub pour avoir définitivement la paix avec ce petit problème...

Répondre